IW STi Forum banner

1 - 20 of 119 Posts

·
Registered
Joined
·
1,264 Posts
Discussion Starter #1 (Edited)
Update 2011.09.16: At this point I'm quite comfortable with saying that this issue was definitely related to the passenger side hatch damper. The issue persisted after spot welds were reinforced, and ceased after the dampers were replaced.

I am now also keeping this updated in my blog as well @ 2008 Subaru Impreza WRX STi Hatch - "theNoise" (Broken welds = Squeak)

Car: 2008 Impreza WRX STi

Problem: Broken welds on roof support near hatch opening causing metal on metal squeaking over bumps or in turns.
Update 2011.08.27; Could this have been misdiagnosed??? <- Click for more information.

Reason denied: Originally Subaru denied claim and voided warranty stating that installation of stiffer springs caused the weld to break.
Update 2011.07.21; SOA called, they're fixing under waranty, *but*... <- Click for more information.

Summary: I installed springs on my car (320lb rates, front & rear) on 2010.09.18. I have proof of invoice and tracking information via FedEx that shows I didn't have these springs in my possession until 2011.09.16. According to the dealer's service records, I first reported this problem to them on 2010.09.08. This means that it had already been occurring and I called them to set up an appointment for them to look at it. Those notes don't go into the system until the dealer takes possession of the car, at least for my dealer.

I went to the dealer today and had them print my service records. There is a 'customer complaint' on there dated 2010.09.08 that states the following;

Complaint: Customer states that the hatch back or something will creak in the rear when driving over a rough road please check and advise...

Cause: Tech traced and found there was a rattle coming from the latch on the rear hatch back door.

Correction: Tech greased the latch and test drove to verify proper operation.
On 2010.10.08 I brought it in because the brakes were squealing, at which time the service manager noticed the hatch squeak. I told him how I've already brought it in for that and they claim they fixed it by re-greasing the latch. He said to have it looked at again at the next service.

On 2011.02.03 I brought it in for service and this is what they have noted regarding the squeak.

Complaint: Customer states that the rear hatch is squeaking please check and advise...

Cause: Tech test drove the vehicle and found the rear mat rubbing on the cargo cover and tech also found the latch in need of lubrication.

Correction: Tech completed the lubrication on the rear hatch latch and also moved the rear cargo mat from the cargo shade and test drove to verify no squeaking from the rear at this time.
On 2011.02.07 I brought it in for the squeak again, and here are the notes.

Complaint: Customer states that there is a squeaking noise coming fromt he rear hatch when driving over bumps please check and advise...

Cause: Tech test drove the vehicle and was not able to duplicate the customer's concern at this time.

Correction: No repairs made at this time.
On 2011.05.13 I brought it in for maintenance and the following was noted regarding the squeak.

Complaint: Customer states there is a metal on metal noise coming from the right rear please check and advise.

Cause: Tech found the noise coming from the drivers rear quarter panel area more time is needed to complete diag.

Correction: Customer is advised and will return at a later date.
I brought it back on 2011.05.18 and here are the notes.

Complaint: Customer states there is a squeak coming from the rear top of the vehicle when going over bumps advise...

Cause: Tech found the creek coming from the rear roof supports. Possible weld broken.

Correction: Subaru has been contacted and factory engineer will come out to inspect vehicle at customer convenience. Customer will be contacted when this is possible.
I did go back again near the end of may, so I'll need to go back and get that service record for the details... but in short the rep didn't even come look at the vehicle, he just told the service manager to deny the claim and void the warranty stating that my stiffened springs caused the issue, which is clearly not the case.

I just gathered the documents I think I'll need, and I'm stopping by the dealer tomorrow to talk to the service manager. I'll try to keep this updated.
 

·
Registered
Joined
·
3,713 Posts
Re: 2008 STi - Broken welds on rear roof support...

Call Subaru of America
Also they cannot void your warranty, only deny a claim based on modification.
 

·
Registered
Joined
·
1,264 Posts
Discussion Starter #5 (Edited)
Re: 2008 STi - Broken welds on rear roof support...

very interested in this. Keep it coming. Damn stealerships
The dealership has actually been quite helpful with this situation, and actually wasn't very enthused about having to tell me they wouldn't cover it, and why. They couldn't really share their view point on the situation once the regional rep provided his input though, their hands are kind of tied.

Call Subaru of America
Also they cannot void your warranty, only deny a claim based on modification.
My warranty expired 2011.05.31 anyways, so that's not a huge deal anyways. However this is an issue that they've been unable to fix for months now, and the service manager showed me in the warranty agreement where any items brought to their attention before the warranty expires would still have to be honored under warranty... if they persist past the expiration date.

I'm calling SOA tomorrow to updated them with details on the situation, I already have the case open with them that I can reference.

I will keep things updated here.
 

·
Registered
Joined
·
3,713 Posts
Re: 2008 STi - Broken welds on rear roof support...

The dealership has actually been quite helpful with this situation, and actually wasn't very enthused about having to tell me they wouldn't cover it, and why. They couldn't really share their view point on the situation once the regional rep provided his input though, their hands are kind of tied.
Yup, they have no say once a regional rep has made a decision. If you have the emails to show invoice date with clear part description and follow up tracking numbers for the springs I think you should be able to make a solid case that this was in fact brought to their attention prior to warranty and misdiagnosed by the dealership at the time.

By the way even though your bumper to bumper is up, which this would fall under, you do realize you still have a 5 year powertrain?
 

·
Registered
Joined
·
1,264 Posts
Discussion Starter #8 (Edited)
Re: 2008 STi - Broken welds on rear roof support...

By the way even though your bumper to bumper is up, which this would fall under, you do realize you still have a 5 year powertrain?
Valid point, I'll be sure to ask about this tomorrow. I need to make sure this rep didn't void that... and if he did, work on getting that reversed.

I'm going to the dealer with the following information regarding the springs; invoice from the manufacturer, the email that contained the tracking number, and the tracking information that shows delivery on the date 2009.09.16.
 

·
Registered
Joined
·
863 Posts
Re: 2008 STi - Broken welds on rear roof support...

And subaru is at it again...man are they a pain in the arse to deal with.
 

·
Registered
Joined
·
1,264 Posts
Discussion Starter #11
Re: 2008 STi - Broken welds on rear roof support...

I called the customer support number listed on subaru.com and updated my case with them, including dates and a summary of the situation all the way up to where the regional rep denied my claim, etc.

I also called the dealer and am waiting for a call back from the service manager to set up a time to come see him, today preferably.
 

·
Registered
Joined
·
1,264 Posts
Discussion Starter #13 (Edited)
Re: 2008 STi - Broken welds on rear roof support...

I took a late lunch and visited the dealer to provide the service manager with the following documents regarding the spring purchase/installation...

-Invoice showing purchase & ship date, associated tracking number listed.
-Dated copy of email from manufacturer that had the invoice attached.
-FedEx shipping notification email, dated.
-FedEx package progress showing delivery date (2010.09.16)

I also brought the service records he printed out for me yesterday, with the original complaint highlighted on 2010.09.08. Reminding him that was the date I left the car with him, after I had already called reporting the issue to make an appointment. Therefore had already been experiencing the issue before the drop off date.

The service manager made copies of them, faxed them to the regional rep, and told me to expect a call tomorrow (2011.07.14).

While there, I inquired about the comment that was made previously about my warranty being voided. He specified that only the warranty pertaining to this part/claim was affected, so my power train warranty is still intact. However, hopefully with this documentation, that voided warranty item can be reversed and this can be handled.

However, even if they do reverse the voided warranty and say they'll repair it, there are some interesting details about the repair I'm not enthused with. Those details I'll enclose at a later time if we get to that point.
 

·
Registered
Joined
·
1,264 Posts
Discussion Starter #14
Re: 2008 STi - Broken welds on rear roof support...

Service manager informed me that he left the regional rep a message today. I asked that he keep me updated as often as possible, even if its to tell me that he hasn't heard back yet.

Patience is wearing quite thin with this issue. I ordered a brake pads, rotors, and braided lines to put on this weekend, but that's all on hold until more develops with this situation.
 

·
Registered
Joined
·
1,264 Posts
Discussion Starter #15
Re: 2008 STi - Broken welds on rear roof support...

I called with service manager about a 30 minutes ago... he spoke with the regional rep today and was informed that it's going to take a couple days to look into this. The service manager said he'd call me immediately after getting getting an update from the regional rep.

I'm not quite sure what needs to be looked into, but I suppose I understand there are policies and procedures that need to be followed in a situation like this. I let him know I'd check in with him on Wednesday if I haven't heard anything.
 

·
Registered
Joined
·
3,713 Posts
Re: 2008 STi - Broken welds on rear roof support...

I'm not quite sure what needs to be looked into
I'm sure each person in the chain has multiple things they're working on so they're not looking at your stuff right away. Rep gets it and reviews it within 24hrs. It goes to SAO and that person will look at it within 24hrs. Until it gets to a decision maker who can overturn the existing denial. Just keep following up so it doesn't go stagnant on someones desk and you'll get an answer soon enough. It's just the way it is in larger companies.
 

·
Registered
Joined
·
2,338 Posts
Re: 2008 STi - Broken welds on rear roof support...

If you can take a pic of it that would be great. I have some creaking and ive got about 20k+ on a suspension.
 

·
Registered
Joined
·
1,264 Posts
Discussion Starter #18
Re: 2008 STi - Broken welds on rear roof support...

If you can take a pic of it that would be great. I have some creaking and ive got about 20k+ on a suspension.
I'd have to remove the headliner to do so, not sure I'll have time this weekend with work and other activities. The service manager pointed to where the plastics surrounding the hatch met up with the fabric and said "its near where the hatch hinges bolt onto the body."
 
1 - 20 of 119 Posts
Top