IW STi Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
156 Posts
Discussion Starter #1 (Edited)
2008 STI , approx. 55000 miles with no mods

Drove about 380 miles yesterday in the rain. Driving around my neighbor looking for a parking spot when...the radio face shut off and speakers had a pulsing sound, airbag light came on, SPORT # switched to Sport, Clock and passenger airbag light flashed in conjunction with pulsing speaker sound, and VDC light near the Coolant Gauge turned on. Then the car went to stall until I disengaged the clutch, which happened 2-3 times.

I finally pulled to the side and turned the vehicle off and restarted it and everything went back to normal and the problem disappeared.

Any ideas? Maybe the chipped key or immobilizer is starting to go? Bad Ground (One of the Radio Ground Straps is a little frayed)?
 

·
Registered
Joined
·
430 Posts
Sounds like short somewhere or wiring that was susceptible to water causing poor connection...maybe run vehicle an use garden hose to get water all over an try to trace it down...or look at all your wires in engine bay fenders etc where something could have happened
 

·
Registered
Joined
·
156 Posts
Discussion Starter #3
Sounds like short somewhere or wiring that was susceptible to water causing poor connection...maybe run vehicle an use garden hose to get water all over an try to trace it down...or look at all your wires in engine bay fenders etc where something could have happened
Jedi - I live in the city and don't have access to a water hose, which sucks.

Im thinking if it is a short I would blow a fuse, and not have multiple portions of the circuit light up. I think the instrument panel wiring harness grounds might not be snug against the frame. My pedal assembly mounting bracket was rewelded (i.e. 7 spot welds) almost 2 years ago, so I am thinking with vibration something may have become loose. I know one of the radio ground straps that attaches to the drivers side VVT solenoid on the engine is frayed but not yet broken.

From the instrument panel wiring harness diagram it seems like the two grounds are on the outskirts of the radio. I have never took notice to where these two ground eyelets are located or screwed into the frame. Any ideas on how to get easy access without pulling the dash?
 

·
Registered
Joined
·
156 Posts
Discussion Starter #4
So I arrived at my car today and the clock was 1:20 hours behind, meaning that the car lost power at some point and time. Checked all connections to battery and all seemed ok. Battery voltage was 13.25V while vehicle was off. Either a loose connection or the battery may have an issue.
 
1 - 4 of 4 Posts
Top