IW STi Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
So my 07 STi with a CSF radiator, the fan keeps cutting my top radiator hose. I am told to order a new SPAL fan, I just don't know the correct size. Has anyone upgraded their radiator fans and what setup did you choose? I know OEM is best but it just keeps cutting... I am aware of the Mishimoto fan set, but I am not reading many good reviews on it. I am aware of trimming it etc but it is just simply too close and the fan needs to be smaller. Appreciate your input on what you guys have done to remedy this problem
 

·
Registered
Joined
·
80 Posts
Discussion Starter #3
Also side note, is gates good enough or is grimmspeed hose better? Here is a pic looking down on engine bay, the bottom of the hose has shredded holes. I just was at M45 three weeks ago for a complete overhaul including fixing this, it lasted 3 weeks... What radiator fan can I get that is smaller and hopefully stronger as well
20200706_172658.jpg
20200706_172707.jpg
 

·
Registered
Joined
·
80 Posts
Discussion Starter #5
Yea that's what the shops have been doing over the years to fix it but I want to fix this permanently... Do you know of any alternative fans besides Mishimoto, I've been told to get a SPAL 12-inch medium profile but I really have no idea if it will fit or whether to get the low profile and would prefer replacing the fan system instead of getting a different radiator if possible.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #6
Anyone that upgraded their radiator and their top hose keeps getting cut, what did you do to resolve?
 

·
Registered
Joined
·
5,464 Posts
Yea that's what the shops have been doing over the years to fix it but I want to fix this permanently... Do you know of any alternative fans besides Mishimoto, I've been told to get a SPAL 12-inch medium profile but I really have no idea if it will fit or whether to get the low profile and would prefer replacing the fan system instead of getting a different radiator if possible.
That is the permanent fix. There are no pre-trimmed hoses available, they are left OEM length (long) so they can be trimmed to taste. Most thicker aftermarket radiators need to have the top hose trimmed to maintain OEM fit and finish and all are different thicknesses. So a trimmed upper hose would only fit a single radiator, but a long one can be trimmed to be used on ANY radiator.

I would HIGHLY recommend sticking with OEM radiators and fan shrouds. Any aftermarket product that is not very expensive is going to be a huge hit to cooling performance. The low dollar brands perform significantly worse than OEM. If you want a step up from OEM, you're looking at +$300 each fan and they are thicker than OEM too. If you want thin AND powerful, then plan on spending well over double that figure. There is a reason why so many recommend the factory fans, because they are very good. Our super expensive radiator even uses them, and we've never come close to running out of cooling capacity even at ungodly power levels and conditions.
 

·
Premium Member
Joined
·
5,470 Posts
Radiator is an X-Line? Chis's favorite 🤣😂

You have to cut the hoses short to use one. Do it at the engine side to move the hose back. I never had an issue with the fan though had thin walled Mishimoto hoses. I just replaced them because when I retired the Xline (want a spare ? it comes with a hoses that have a wear spot in a different location :) :) :) I replaced it with a "normal" radiator and the hoses were too short. I decided I liked the thin wall Mishimoto hoses.
 

·
Registered
Joined
·
393 Posts
+1 cut the hose on the engine side shorter...i had the same thing happen until i corrected the hose length...no more cut hoses now!!!
 

·
Registered
Joined
·
80 Posts
Discussion Starter #10
Ok so sounds like forget about replacing the fans and just get a new hose and trim it properly. Is gates fine, I would like a grimmspeed but I'm worried about it happening again and ruining it, so is gates ok quality or should I try and get OEM, I'm going order a back up, thoughts on different brands gates vs OEM vs say grimmspeed? I also noticed the whole radiator and fan shroud have a little wiggle and essentially lean back towards the engine so I'm trying to figure out what to tighten to get my radiator system tight and not move
 

·
Registered
Joined
·
29 Posts
The OEM hose is perfectly fine. You don't have to drop $$$ any special hose.

What you have to do is fit the hose to your application. There is no hard rule on how much to trim off.
You may need to trim on both ends of the hose to get the right fit.

Trim small amounts from one side, check fit, repeat, until you get it right so there are no clearance issues.
 

·
Registered
Joined
·
80 Posts
Discussion Starter #12
Ok so bought the last hose from a dealership, really wanted two in case. I trimmed and adjusted, seems half a thumb finger nail from the fans and maybe a little more the pulley. Here are some pics, let me know guys what I should change etc
20200711_105418.jpg
20200711_105633.jpg
20200711_105920.jpg
20200711_105926.jpg
20200711_105819.jpg
 

·
Premium Member
Joined
·
5,470 Posts
Hard for me to tell in the pics. Looks to me that the hose is not parrel to the spcae it has, but If its not touching it is fine. Half a thumbnail should be plenty.
 
  • Like
Reactions: ksantucci

·
Registered
Joined
·
80 Posts
Discussion Starter #14
I don't know, anymore trimmed and it is hitting the pulley nut, and any longer and the fan will hit. It is a tight fit, but I think its working now. Hope it lasts...
 
1 - 14 of 14 Posts
Top