Exterior Turn signal failure - Page 2 - Subaru Impreza WRX STI Forums: IWSTI.com
STI Forum
Join
Start New Thread Create Account Advertise FAQ Members List Contact
Turn signal failure
Turn signal failure
Go Back   STI Forums > > > Exterior Turn signal failure
Reply
 
Thread Tools
Old 06-30-19, 03:04 PM   #11
Grandprix
Advanced Contributor Level 1
Feedback Score: 0 reviews
 
Car: 2017 Pure Red STI
Fav Mod: Interior exterior LEDs
My Threads
Posts: 163
My Subaru Parts for sale

Join Date: Jan 2015
Location: Floriduh native
Grandprix is on a distinguished road
Default Re: Turn signal failure

Sequential turn signal led lights ordered. We shall see.
Grandprix is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 07-03-19, 08:54 AM   #12
Grandprix
Advanced Contributor Level 1
Feedback Score: 0 reviews
 
Car: 2017 Pure Red STI
Fav Mod: Interior exterior LEDs
My Threads
Posts: 163
My Subaru Parts for sale

Join Date: Jan 2015
Location: Floriduh native
Grandprix is on a distinguished road
Default Re: Turn signal failure

No luck. Still an intermittent failure.
Can somebody do me a favor and let me know if your hazard selector button in the car lights up when pressed? Mine does not and I was curious if that’s part of the problem. Nothing in the owners manual.
Thanks.
Grandprix is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 07-09-19, 05:07 PM   #13
Grandprix
Advanced Contributor Level 1
Feedback Score: 0 reviews
 
Car: 2017 Pure Red STI
Fav Mod: Interior exterior LEDs
My Threads
Posts: 163
My Subaru Parts for sale

Join Date: Jan 2015
Location: Floriduh native
Grandprix is on a distinguished road
Default Re: Turn signal failure

Quote:
Originally Posted by Grandprix View Post
No luck. Still an intermittent failure.
Can somebody do me a favor and let me know if your hazard selector button in the car lights up when pressed? Mine does not and I was curious if that’s part of the problem. Nothing in the owners manual.
Thanks.
Anyone?
Grandprix is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 07-10-19, 10:57 AM   #14
navin'swrxsti
Contributor
Feedback Score: 0 reviews
 
Fav Mod: Coming Soon
My Threads
Posts: 66
My Subaru Parts for sale

Join Date: Sep 2015
navin'swrxsti is an unknown quantity at this point
Default Re: Turn signal failure

Hazard button itself does not blink when pressed
navin'swrxsti is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 07-10-19, 12:26 PM   #15
Grandprix
Advanced Contributor Level 1
Feedback Score: 0 reviews
 
Car: 2017 Pure Red STI
Fav Mod: Interior exterior LEDs
My Threads
Posts: 163
My Subaru Parts for sale

Join Date: Jan 2015
Location: Floriduh native
Grandprix is on a distinguished road
Default Re: Turn signal failure

Quote:
Originally Posted by navin'swrxsti View Post
Hazard button itself does not blink when pressed
Thank you, that helps.
Grandprix is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 07-11-19, 11:36 AM   #16
Grandprix
Advanced Contributor Level 1
Feedback Score: 0 reviews
 
Car: 2017 Pure Red STI
Fav Mod: Interior exterior LEDs
My Threads
Posts: 163
My Subaru Parts for sale

Join Date: Jan 2015
Location: Floriduh native
Grandprix is on a distinguished road
Default Re: Turn signal failure

I am at a loss.
New Diode Dynamics flasher relay. Left circuit dead in turn signal and hazard mode. Right circuit perfect.
New Subispeed flasher relay. As above.
Original flasher relay Hyperblink and intermittent left circuit.
Valenti flasher relay. Intermittent left circuit in hazard and turn signal mode. Right circuit perfect. Works better than any other relay, but intermittent.
Checked all light housings, connections and wires.
Disconnected the battery.
Last hope is take to stealership and have them check the MFS and hope they replace under warranty.
Completely baffled. I hate chasing intermittent faults.
Grandprix is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 07-15-19, 01:45 PM   #17
Grandprix
Advanced Contributor Level 1
Feedback Score: 0 reviews
 
Car: 2017 Pure Red STI
Fav Mod: Interior exterior LEDs
My Threads
Posts: 163
My Subaru Parts for sale

Join Date: Jan 2015
Location: Floriduh native
Grandprix is on a distinguished road
Default Re: Turn signal failure

Stealership messed around for an hour and installed the original incandescent bulb. Blamed it on the LEDs.
I now think it may be a loose connection in the plastic plug where the bulb is installed.
Just going to tape everything tight and tie rap the excess wire before reinstalling the LED. This can’t be rocket science. Hopefully the Diode Dynamics flasher relay will work as advertised. Otherwise, I’ll have to sell it cheap.
Bright side, the dealer didn’t charge me for the diagnosis.
Grandprix is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 07-17-19, 10:44 AM   #18
VA STI
Advanced Contributor Level 4
Feedback Score: 0 reviews
 
Fav Mod: Coming Soon
My Threads
Posts: 419
My Subaru Parts for sale

Join Date: May 2017
VA STI will become famous soon enough
Default Re: Turn signal failure

Changing turn signals to LEDs may in fact be linked to why it doesn't work. I believe the turn signals use resistance in their timings (so when your bulb blows the indicator flashes faster). Maybe using LEDs instead of regular bulbs is making them act wonky?
VA STI is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 07-17-19, 12:34 PM   #19
Grandprix
Advanced Contributor Level 1
Feedback Score: 0 reviews
 
Car: 2017 Pure Red STI
Fav Mod: Interior exterior LEDs
My Threads
Posts: 163
My Subaru Parts for sale

Join Date: Jan 2015
Location: Floriduh native
Grandprix is on a distinguished road
Default Re: Turn signal failure

The flasher relay compensates for the lower resistance.
Grandprix is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 07-22-19, 01:52 PM   #20
Grandprix
Advanced Contributor Level 1
Feedback Score: 0 reviews
 
Car: 2017 Pure Red STI
Fav Mod: Interior exterior LEDs
My Threads
Posts: 163
My Subaru Parts for sale

Join Date: Jan 2015
Location: Floriduh native
Grandprix is on a distinguished road
Default Re: Turn signal failure

That’s it! I am done chasing this effing problem. All good for a week. Today, the nonworking left circuit reappeared.
Going to switch my fronts back to incandescent. Obviously, my car's electrical system can’t handle full up LEDs.
Call me pissed in FLA.
Grandprix is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


New To Site? Need Help? More

All times are GMT -8. The time now is 12:31 AM.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Designed & Powered by Domain Architect
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.