Thermometer not working: displays -22. - Page 3 - Subaru Impreza WRX STI Forums: IWSTI.com
STI Forum
Join
Start New Thread Create Account Advertise FAQ Members List Contact
Go Back   STI Forums > > > > Thermometer not working: displays -22.
Reply
 
Thread Tools
Old 03-04-09, 07:04 PM   #21
GT42RR
Becoming A Contributor
Feedback Score: 0 reviews
 
Car: White 08 STI
Fav Mod: Cobb AP
My Threads
Posts: 11
My Subaru Parts for sale

Join Date: Jun 2008
Location: Ancaster Ontario
GT42RR is an unknown quantity at this point
Default Re: Thermometer not working: displays -22.

yes they are cleaning up the pins and adding some dielectric grease. The pins on mine were coroded right off so they had to replace that cap.
GT42RR is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 03-05-09, 12:35 PM   #22
racerx321
Becoming A Contributor
Feedback Score: 0 reviews
 
Car: 08 DGM STI, 06 MX-5
Fav Mod: Driving school
My Threads
Posts: 11
My Subaru Parts for sale

Join Date: Mar 2007
Location: Minnesohta
racerx321 is on a distinguished road
Default Re: Thermometer not working: displays -22.

That last sentence in the bulletin about climate control is interesting. My thermometer went out last week (yes, after a touchless car wash) and the result was a climate control system that was MUCH improved. When the thermometer was out, I could actually select a heat output that would not burn my hands in front of the vent! With a recent warm-up in temps here, the thermometer is working again, but now the lowest temp setting on the climate control results in super-hot heat output again.

I think I'll have the dealer check/fix the pin problem, and then I'll probably remove the thermometer probe to allow me actual control of the heat output. Has anyone else with broken thermometers experienced anything similar?
racerx321 is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 03-05-09, 01:30 PM   #23
GT42RR
Becoming A Contributor
Feedback Score: 0 reviews
 
Car: White 08 STI
Fav Mod: Cobb AP
My Threads
Posts: 11
My Subaru Parts for sale

Join Date: Jun 2008
Location: Ancaster Ontario
GT42RR is an unknown quantity at this point
Default Re: Thermometer not working: displays -22.

When the outside temp guage fails the auto setting will not work with the climate control. It cant operate without knowing the outside temp.
GT42RR is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 04-02-09, 12:42 PM   #24
hnasko
Advanced Contributor Level 1
Feedback Score: 0 reviews
 
Car: 08 STI BLK
Fav Mod: Chrome Mustache
My Threads
Posts: 101
My Subaru Parts for sale

Join Date: Jan 2008
Location: Boston
hnasko is an unknown quantity at this point
Default Re: Thermometer not working: displays -22.

Many thanks GT42RR. My dealer said that the service bulletin they received did not have the line about the erratic High Beam usage. Thanks Canada.

They also did not want to believe that their customer figured it out before they did.
hnasko is offline  
Likes 1 Dislikes 0
 
Reply With Quote
Old 04-04-09, 03:42 PM   #25
threader
Advanced Contributor Level 2
Feedback Score: 0 reviews
 
Fav Mod: RalliSpec SB, AMR T60R, 73mm CAI, Perrin TBE & FMIC, DW 1000cc, WLB 255L, COBB AP - ProTune - 93oct
My Threads
Posts: 281
My Subaru Parts for sale

Join Date: Jan 2008
Location: Montreal
threader is an unknown quantity at this point
Default Re: Thermometer not working: displays -22.

Thanks so much for this. I first got my 08 STI in Jan 2008 and had no electrical issues last winter. This winter my battery was always going dead and my neighbor who moves my car for the snow contractor kept telling me that my battery was going dead while I was away on business. I brought the car in to Subie dealer and they just changed my battery for new. I thought my problems were over. Same thing with new battery. My neighbor was stuck recharging it. Now it's all clear. I have the thermometer issue and it's clearly shorting the electical system while I'm away. I'm going back to Subie service with this inhand. thanks guys!

Quote:
Originally Posted by GT42RR View Post
Here is the info I got from my dealer today.
threader is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 03-17-11, 06:34 AM   #26
cdv478
Advanced Contributor Level 1
Feedback Score: 0 reviews
 
Car: Lightning Red 08 STI
Fav Mod: Rally Armor UR flaps; my car would be trashed without them.
My Threads
Posts: 180
My Subaru Parts for sale

Join Date: Nov 2008
Location: San Diego, California
cdv478 is an unknown quantity at this point
Default Re: Thermometer not working: displays -22.

I performed this bulletin on my car yesterday. After over 2 years of time to become aware of this problem, I would assume dealers would know how to fix it. But at least one, Michael Hohl Subaru, in Carson City, Nevada, doesn't.

I took it in twice for this problem. It couldn't be duplicated, so on Saturday when it acted up while leaving the dealer, I took the car back and let it idle in the service drive so I could demonstrate the problem. They didn't want to look at it and said they would call me back Monday. Today is Thursday and no call. This is why I fix things myself. End of dealer rant.

To access the connector, there are 4 tabs that need to be released so you can lift the main fuse panel. You do not need to remove the bolts securing the fuse box. The connectors are just beneath the fuse panel and inside the fuse box. Removing the battery helped a lot with accessibility. The suspect connector is on the forward side of the fuse box.

The corrosion was very obvious. It was both under and on top of the connector, and I was concerned the pins may have corroded away. After removing the connectors, I found no serious damage. I used CRC electrical cleaner and dielectric grease to remove and prevent the return of corrosion, and now the thermometer and auto setting for the a/c and heater work fine. Its an easy procedure if nothing is damaged.

Thanks for posting this bulletin!
cdv478 is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 06-13-11, 03:41 AM   #27
cdv478
Advanced Contributor Level 1
Feedback Score: 0 reviews
 
Car: Lightning Red 08 STI
Fav Mod: Rally Armor UR flaps; my car would be trashed without them.
My Threads
Posts: 180
My Subaru Parts for sale

Join Date: Nov 2008
Location: San Diego, California
cdv478 is an unknown quantity at this point
Default Re: Thermometer not working: displays -22.

Update to my previous post:

The temperature began fluctuating again shortly after my last post. I took it to a different dealer and they replaced the outside temp sensor. That didn't fix the problem.

This time I used Caig Deoxit to clean treat everything. I opened the connector blocks and cleaned them, then applied a light preservative coating of Caig to protect everything.

For the first week or so the temp still fluctuated erratically and gave fail indications several times. But, its been over a month now with temps from the 20s to the 80s and the problem appears to be gone. Evidently the cleaner had to penetrate the pins or wiring to neutralize the corrosion. Now the thermometer works correctly.
cdv478 is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 09-28-17, 05:31 PM   #28
careercadaver
Master Contributor Level 1
Feedback Score: 5 reviews
 
Car: 2009 DGM STi Hatch
Fav Mod: Just one?
My Threads
Posts: 710
My Subaru Parts for sale

Join Date: Aug 2010
Location: Niles, MI
careercadaver will become famous soon enoughcareercadaver will become famous soon enough
Default Thermometer not working: displays -22°.

Had this same issue but it affected my high beams. They would slowly engage like my high beams were underpowered. I left the connector unplugged and had the same issue with -22 showing up. My display did black out after a few minutes.







Just in case the location is not clear...









I replaced everything that was green.

Last edited by careercadaver; 09-28-17 at 06:23 PM.
careercadaver is offline  
Likes 1 Dislikes 0
 
Reply With Quote
Old 07-06-19, 10:24 PM   #29
STiChillin
Becoming A Contributor
Feedback Score: 0 reviews
 
Car: CBS 15 STI
Fav Mod: FP FTZ Green Turbo
My Threads
Posts: 14
My Subaru Parts for sale

Join Date: Sep 2011
Location: Chico, CA
STiChillin is an unknown quantity at this point
Default Re: Thermometer not working: displays -22�.

CareerCadaver you the real MVP!

I'm going to take a stab at it tomorrow. I'm definitely tired of not having high beams lol I need my LEDs to beam those idiots who drive with their brights on lol.
STiChillin is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to tell if my DCCD is working properly? BBBsti LTD Drivetrain Components 2 01-09-07 01:53 PM
*HELP!* window washer not working!! Wes General Subaru Discussion 17 11-22-06 11:13 AM
Interior So my airbags will stop working if I get different seats? WTF? Jag32 GD-General 32 10-23-06 08:57 PM
Interior A/C not working after HVAC red mod... non-ricer GD-General 14 05-24-06 06:24 PM
Exterior Washer sprayer not working?? slashSTI GD-General 6 09-17-03 06:30 AM


New To Site? Need Help? More

All times are GMT -8. The time now is 01:58 AM.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Designed & Powered by Domain Architect
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.