Problems after getting tuned... - Subaru Impreza WRX STI Forums: IWSTI.com
STI Forum
Join
Start New Thread Create Account Advertise FAQ Members List Contact
Problems after getting tuned...
Problems after getting tuned...
Go Back   STI Forums > > > Problems after getting tuned...
Reply
 
Thread Tools
Old 11-26-13, 09:48 PM   #1
Freakin-Rican
Becoming A Contributor
Feedback Score: 0 reviews
 
Car: 06' WRB STI
Fav Mod: GT35R
My Threads
Posts: 41
My Subaru Parts for sale

Join Date: Jan 2012
Location: Pearland, TX
Freakin-Rican is an unknown quantity at this point
Default Problems after getting tuned...

I've searched and cannot really find anything to help me out.... Car is a 2006 STI, just got it tuned 3 weeks ago after having to pull out my old GT35R and switched it with a comp CT3-6262. Supporting mods are 2200cc injectors built block, EL headers, ported TGV deletes,perrin fmic, dual deatschwerks 300lph fuel pumps.. Car is tuned on E85. Before switching turbos the car ran like factory on e85... It would idle fine, not smoke and it even idled fine even without a tune. After getting my new tune the cars idle when I put the clutch in would bounce from 1k-2k for a bit until it would finally settle, I was told this was because the new tuned needed to settle in.. They also kept telling me they wouldn't be able to get it to ever get the car to run right because of the size of the injectors and the car would smoke a lot on WOT pulls... The car never did any of this before the tune. I could go wot and barely barely any smoke whatsoever, it would also idle just fine with no issues at all and start up as soon as I turned the key.. Another problem which now I find myself having to wait for the car to turn over for about 10 seconds before starting... Also they disabled the cel codes for the cyl misfires. They still keep coming on and when I took it back to them they didn't know why it was coming back and said they couldn't do anything about the idle due to the injectors being so large... Sorry for the essay I just wrote lol just don't know what to do at this point.
Freakin-Rican is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 11-26-13, 11:42 PM   #2
AllSpeedInnovations
Account Inactive
Feedback Score: 2 reviews
 
My Threads
Posts: 467
My Subaru Parts for sale

Join Date: Aug 2013
AllSpeedInnovations is on a distinguished road
Default Re: Problems after getting tuned...

The first step would be to find a new tuner, this place doesn't sound very helpful. This will solve most of your problems.

Are you saying they have disabled the misfire codes (poor decision if they did) and you are getting a CEL for a misfire? If that is the case, step 2 is to have the new tuner who knows what they are doing look into the cause of the misfire.
AllSpeedInnovations is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 11-27-13, 03:17 AM   #3
ENDRTuning
Account Inactive
Feedback Score: 1 reviews
 
Car: 15 WRX
Fav Mod: Tooning!
My Threads
Posts: 193
My Subaru Parts for sale

Join Date: Nov 2013
Location: Dayton Ohio
ENDRTuning is an unknown quantity at this point
Default Re: Problems after getting tuned...

So were the injectors present on the old tune? The smoke thing is somewhat normal when you have alot of power and burn a rich fuel mixture.

But I guess that would depend on how much smoke were talking. E85 needs work to get it right on the idle / low end side of things.

I would agree with ASI that something doesnt seem right with the shop. Your misfiring due to poor tuning of the injectors, and instead of tuning them more, they just tried to disable your codes. What they didnt know is that just prevents the permanent CEL. It doesnt stop the temporary one or the one you can get to flash from misfires.
ENDRTuning is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 11-27-13, 05:30 AM   #4
NIQUE303
Advanced Contributor Level 1
Feedback Score: 0 reviews
 
Car: BLACK 08 WRX STI
Fav Mod: RINO LINING
My Threads
Posts: 140
My Subaru Parts for sale

Join Date: Mar 2013
Location: DENVER CO
NIQUE303 is an unknown quantity at this point
Default Re: Problems after getting tuned...

Find a new tuner ASAP!!
NIQUE303 is offline  
Likes 1 Dislikes 0
 
Reply With Quote
Old 11-27-13, 06:06 AM   #5
Freakin-Rican
Becoming A Contributor
Feedback Score: 0 reviews
 
Car: 06' WRB STI
Fav Mod: GT35R
My Threads
Posts: 41
My Subaru Parts for sale

Join Date: Jan 2012
Location: Pearland, TX
Freakin-Rican is an unknown quantity at this point
Default Re: Problems after getting tuned...

Quote:
Originally Posted by ENDRTuning View Post
So were the injectors present on the old tune? The smoke thing is somewhat normal when you have alot of power and burn a rich fuel mixture.

But I guess that would depend on how much smoke were talking. E85 needs work to get it right on the idle / low end side of things.

I would agree with ASI that something doesnt seem right with the shop. Your misfiring due to poor tuning of the injectors, and instead of tuning them more, they just tried to disable your codes. What they didnt know is that just prevents the permanent CEL. It doesnt stop the temporary one or the one you can get to flash from misfires.
Yea the injectors size hasn't changed between tunes.. I understand smoke on wot but even taking off from a dead stop normally I get a big cloud of smoke everytime.. And the car will hiccup when I first go wot... Nod just driving it daily it has a lot of hiccups in it. He kept telling me that there's. Nothing they can do about it. That the injector size is just way to big for my car. And when I tell them that the car ran fine with the other tune they just really do not say anything except they don't know
Freakin-Rican is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 03-08-14, 04:37 PM   #6
unixfool
Advanced Mastery Level I
Feedback Score: 2 reviews
 
Fav Mod: Nameless CAI
My Subaru Parts for sale

Join Date: Nov 2011
Location: Northern VA
unixfool is an unknown quantity at this point
Default Re: Problems after getting tuned...

I know this is an old post, but what became of this issue? Was it resolved? What was the root cause?

You didn't say what tune shop tuned your car.
unixfool is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Any current WRX problems? MYSTi General Subaru Discussion 31 12-11-12 02:29 PM
FS (NY): 2004 Subaru Impreza WRX Stage 2 Pro Tuned Utica NY kornmart Used STIs For Sale 5 10-13-09 07:07 PM
Very big problems with 08 Sti Ecu enniorancati ECU Tuning & Performance Electronics 4 08-07-09 12:58 AM
2009 Sti problems vilar17 GR-General 58 07-29-09 09:43 AM
BIG Problems with my car, what should I do? Shaner Warranty / Service Issues 25 10-08-06 11:55 AM


New To Site? Need Help? More

All times are GMT -8. The time now is 02:41 PM.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Designed & Powered by Domain Architect
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.