R.diff temp light is flickering - Subaru Impreza WRX STI Forums: IWSTI.com
STI Forum
Join
Start New Thread Create Account Advertise FAQ Members List Contact
R.diff temp light is flickering
R.diff temp light is flickering
Go Back   STI Forums > > > R.diff temp light is flickering
Reply
 
Thread Tools
Old 07-03-12, 12:30 PM   #1
dharvey1020
Becoming A Contributor
Feedback Score: 0 reviews
 
Fav Mod: Coming Soon
My Threads
Posts: 18
My Subaru Parts for sale

Join Date: Dec 2008
dharvey1020 is an unknown quantity at this point
Default R.diff temp light is flickering

well on my way to work today the R.diff temp light came on. It was weird though cause the light wasen't that bright and it was flickering on and off. Also the longer i drove the less the light would come on untill it finally stay off. Is the normal operation for this light or do i have a shorted sensor? Also what do i do for checking this out and what could be wrong?


Thanks
Dave
dharvey1020 is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 07-03-12, 12:53 PM   #2
Rum
Advanced Mastery Level I
Feedback Score: 2 reviews
 
Car: DGM 08 STI
Fav Mod: PS fluid cooler
My Subaru Parts for sale

Join Date: Mar 2008
Location: Redondo Beach, CA
Rum is an unknown quantity at this point
Default Re: R.diff temp light is flickering

you should check your rear diff and see if the sensor is busted up, wires frayed, etc. You should also make sure the diff doesn't have any obviouos problems, like leaking and what not.

Either the sensor is shot or your diff is in fact overheating. The sensor is easy to break when replacing the diff fluid - has someone done this on your car recently?
Rum is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 07-03-12, 01:09 PM   #3
MSMStannyl
Advanced Contributor Level 1
Feedback Score: 0 reviews
 
Car: SWP 2011 WRX
Fav Mod: Coming Soon
My Threads
Posts: 102
My Subaru Parts for sale

Join Date: Mar 2012
MSMStannyl is an unknown quantity at this point
Default Re: R.diff temp light is flickering

I wonder if it might be low on fluid. With it flickering it sounds like the fluid level might be right at the point of setting the sensor off. Perhaps as it get's hotter, the fluid expands just enough to not set the sensor off?

Just a thought tho.
MSMStannyl is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 07-03-12, 03:07 PM   #4
H&K
Contributor
Feedback Score: 1 reviews
 
Car: PSM 05 STi
Fav Mod: APS,RCE T2s
My Threads
Posts: 54
My Subaru Parts for sale

Join Date: Jun 2010
Location: CT
H&K is an unknown quantity at this point
Default Re: R.diff temp light is flickering

Its most likely the ground wire connection mine was corroded and did the same thing as yours.

on the gd its on the right side of the diff you will see a wire loom that looks like it goes up into the diff mount
H&K is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 07-04-12, 04:13 AM   #5
dharvey1020
Becoming A Contributor
Feedback Score: 0 reviews
 
Fav Mod: Coming Soon
My Threads
Posts: 18
My Subaru Parts for sale

Join Date: Dec 2008
dharvey1020 is an unknown quantity at this point
Default Re: R.diff temp light is flickering

Thanks for all the tips the dif has never been touched. 37000 miles. When i got home the other day i looked at the dif. It was warm to the touch but not hot, and i didn,t see any leaks. I with u guys i think its a ground or just barly low. What is the fill level for the dif

Thank u
Dave
dharvey1020 is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 07-04-12, 04:15 AM   #6
Sabrewings
Advanced Mastery Level V
Feedback Score: 7 reviews
 
Fav Mod: 1 Meter Fuel Line
My Subaru Parts for sale

Join Date: Sep 2009
Location: DC area
Sabrewings is on a distinguished road
Default Re: R.diff temp light is flickering

Quote:
Originally Posted by dharvey1020 View Post
What is the fill level for the dif
Up to the bottom of the fill hole (sensor hole).

As for your problem, it's most likely the ground. I've seen others have the same symptoms and it's been the ground that needed cleaning.
Sabrewings is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 07-04-12, 05:44 AM   #7
badcop
Advanced Contributor Level 5
Feedback Score: 1 reviews
 
Fav Mod: RCE T2's/Work 11r's
My Threads
Posts: 554
My Subaru Parts for sale

Join Date: Nov 2010
Location: North Jersey
badcop is an unknown quantity at this point
Default

Ground wire is loose. Mine does the same thing.
badcop is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 10-08-18, 11:30 AM   #8
RA_011
Joined the Conversation
Feedback Score: 0 reviews
 
Car: Black STI-RA
Fav Mod: Tires
My Threads
Posts: 4
My Subaru Parts for sale

Join Date: Sep 2018
Location: Jersey Shore
RA_011 is an unknown quantity at this point
Default Re: R.diff temp light is flickering

Sorry to resurrect an old thread but...
I have a brand new type RA. 2k on the clock. Did my first track day with it yesterday. Every session, 20min in, the R. Diff Temp light came on steady. I immediately came in to pit, and let it cool. It was fine again on the next session until 20min in.

No question, I was driving it pretty damn hard and under higher than normal stress. HOWEVER, I was previously running my '17 STI at the same track, never had this issue.

Any insight? Should I have Subaru take a look to see if it's the sensor? It makes sense that it would come on when the oil is obviously heating up and responds appropriately to cool down. BUT, this car is supposedly more track focused than my stock STI from last year. I really don't think this is the absolute limit for this car. If it is, I made a poor choice in track car.

Thanks for any help.
RA_011 is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 08-28-19, 12:43 PM   #9
NewShockerGuy
Advanced Mastery Level I
Feedback Score: 3 reviews
 
Car: 05' STI
Fav Mod: Defi gauges, or TXS TBE or JDM sidemarkers...arg!
My Subaru Parts for sale

Join Date: Nov 2004
Location: NOVA VA/DC
NewShockerGuy is an unknown quantity at this point
Default Re: R.diff temp light is flickering

Mine flickers after I wash the car and or when I first drive... then as it warms up the light goes away.

I have checked the ground and that appears fine. I even sanded the corrosion off and use dielectric grease. Still have the same problem. I know my diff fluid isn't low because I checked and filled it to make sure.

I guess it could be the sensor but at $150 I'm hesitant to just replace it if I experience the same thing.

My defi EGT gauge reads all wonky after I wash the car, then a few hours later works perfectly fine..lol

-Nigel
__________________
~NSG~
NewShockerGuy is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
06-07 JDM Tail Light Mod badcop DIY Mods & Installations 3 06-15-13 02:26 AM
Interior Cluster Light flickering nofoo GD-General 5 04-01-10 05:37 AM
Get your defi parts before the price increase jan 1st!!! read inside importimage Vendor Announcements & Project Buildups 10 01-01-09 08:56 AM
Get your defi parts before the price increase jan 1st!!! read inside importimage Vendor Announcements & Project Buildups 1 12-09-08 07:10 PM
Rear Diff Oil Temp Light Jrags87 Drivetrain Components 2 09-05-06 07:38 AM


New To Site? Need Help? More

All times are GMT -8. The time now is 02:05 PM.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Designed & Powered by Domain Architect
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.