Subaru Impreza WRX STI Forums: IWSTI.com - View Single Post - GR Hatch: Don's 08 STI. STI Hatchback/Wagon or bust!
View Single Post
Old 10-18-17, 05:31 PM  
STIGR-Wagon-Dad
Master Contributor Level 1
 
Car: DGM 08 WRX STI Zenki
Fav Mod: RalliTek sway bars+ Kartboy endlinks, Synapse Engineering Diverter valve
My Threads
Posts: 761
My Subaru Parts for sale

Join Date: Mar 2009
Location: SoCal
STIGR-Wagon-Dad has a spectacular aura aboutSTIGR-Wagon-Dad has a spectacular aura about
Default Re: Don's 08 STI. STI Hatchback/Wagon or bust!

My car had been plagued with knocking and misfires for the last 6 months. I've tried colder spark plugs to non projected and it still knocked and misfired. I did notice from day one, the car suffered from engine or alternator noise which can be heard through the old iPod integration and AM radio. It didn't affect the stock performance and improvements were noticeable when I added ground wires to the engine. Perhaps the alternator is going out. I did have success with voltage stabilizers with past project cars. They were a big improvement in drivability and added power. My guess is that the AE86(JDM) had a tiny factory battery, a 55amp alternator, and poor grounding. I didn't expect to see improvement with the STI due to it having a US spec battery, a high output alternator, and superior grounding. I was running out of ideas as I reduced gap, tried different spark plugs, new coil packs, running 91 octane, and injector cleaner. Then, with looking into EMI/RFI, I revisited the voltage stabilizers. I was going to buy a Sun hot inazma, but it was discontinued. The folks at Kamispeed substituted with the Sard racing electrical sweeper. That did the trick! A lot cheaper than replacing an alternator. I was suffering from EMI/RFI induced misfires and knocking. It was probably the culprit in messing with the MAF sensor, too.

Sent from my SM-G955U using Tapatalk
STIGR-Wagon-Dad is offline  
Likes 0 Dislikes 0
 
Reply With Quote