Engine Engine keeps shutting off after start..on a new build - Subaru Impreza WRX STI Forums: IWSTI.com
STI Forum
Join
Start New Thread Create Account Advertise FAQ Members List Contact
Engine keeps shutting off after start..on a new build
Engine keeps shutting off after start..on a new build
Go Back   STI Forums > > > Engine Engine keeps shutting off after start..on a new build
Reply
 
Thread Tools
Old 08-19-19, 11:21 AM   #1
MY15STI
Advanced Contributor Level 2
Feedback Score: 1 reviews
 
Fav Mod: Coming Soon
My Threads
Posts: 284
My Subaru Parts for sale

Join Date: May 2014
Location: SOCAL
MY15STI is on a distinguished road
Default Engine keeps shutting off after start..on a new build

Not sure where to start the diagnosis, here is my latest problem...

Just installed radium fuel rails (with dampers) and new PPTE hose lines for e85 on my newly built 15 STI. For some strange reason, after i took the car home from my friend's shop, the engine cuts off immediately after i push-button start it. I would need to clutch out, turn off the engine, then to restart it with clutch in. It takes about one to four starts to get it started. But once it starts, it drives totally fine with the base map (not completely tuned yet, but it is for my setup).

Not sure what is causing it, it would start fine before the fuel rails got put on. The fuel pressure is at 42psi when i turn on the engine, it just cuts off as soon as i start it. May be from a loose /bad ground? Not fault code either.


The engine was newly built with forged pistons, new spark plugs (gapped), 1700 cc injectors, cobb flex fuel kit, fuel pressure regulator, Blouch 1.5 XT dom turbo, FMIC, killerbee ELH, radium in-tank fuel pump housing with WB 450 pump hard-wire, and etc.

The FPR and flex fuel kit are on the return line.

Thanks. Any advice will be appreciated.
MY15STI is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 08-19-19, 09:12 PM   #2
Jedi03
Advanced Contributor Level 2
Feedback Score: 0 reviews
 
Car: Blue 2009 STi Hatch
Fav Mod: Coming Soon
My Threads
Posts: 232
My Subaru Parts for sale

Join Date: Feb 2017
Jedi03 is on a distinguished road
Default Re: Engine keeps shutting off after start..on a new build

based on my experience probably to much fuel as not tuned for new fuel setup...im still getting parts as I was hoping could just throw on FPR and call it a day to get rid of my stumble along with 1300 injectors..
Jedi03 is offline  
Likes 1 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


New To Site? Need Help? More

All times are GMT -8. The time now is 01:30 AM.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Designed & Powered by Domain Architect
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.