2013 GR STI Loss of Power - Subaru Impreza WRX STI Forums: IWSTI.com
STI Forum
Join
Start New Thread Create Account Advertise FAQ Members List Contact
2013 GR STI Loss of Power
2013 GR STI Loss of Power
Go Back   STI Forums > > > 2013 GR STI Loss of Power
Reply
 
Thread Tools
Old 09-23-19, 01:49 PM   #1
SpicyMango
Joined the Conversation
Feedback Score: 0 reviews
 
My Threads
Posts: 2
My Subaru Parts for sale

Join Date: Sep 2019
SpicyMango is an unknown quantity at this point
Default 2013 GR STI Loss of Power

Hey guys, new to the forums and subaru’s, just lately purchased a 13 hatch in lieu of my Focus ST. I’ve been driving it over the weekend and having an absolute blast, until my mom wanted to take a ride in it so as I was showing her the motions, after a 3/4 throttle 2nd + 3rd gear pull my car began to run a little rough. It was mostly audible cues, definitely sounded like it was missing a beat on idle and sitting still would definitely shake a little bit, and under power it would make up to 9 lbs of boost though it wouldn’t put me back in my seat like it should. I already had to fix an boost leak on the vehicle so I took a look around all the charge pipes, and refitted all the hose clamps, no issues to be found there. I’m wondering if it could be something like exhaust headers leaking somewhere, a wastegate issue, or if it’s more serious or symptomatic of ringland failure, which I understand the concept of, just not too familiar with.
SpicyMango is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 09-23-19, 02:43 PM   #2
SpicyMango
Joined the Conversation
Feedback Score: 0 reviews
 
My Threads
Posts: 2
My Subaru Parts for sale

Join Date: Sep 2019
SpicyMango is an unknown quantity at this point
Default

Would like to add, car is not stock. Previous owner had everything done by IAG, as we are local, including fuel pump, lines, rails, injectors, boost controller, equal length headers, tmic, intake, airbox, and not too much else, some loose odds and ends. No CEL’s thrown after rich code was resolved due to boost leak issue.
SpicyMango is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 09-23-19, 08:47 PM   #3
UrdnotWrexSTi
Silver Member
Feedback Score: 2 reviews
 
Car: Aspen White GR STi
Fav Mod: Coilovers
My Subaru Parts for sale

Join Date: Jan 2015
Location: A-town, CO
UrdnotWrexSTi will become famous soon enough
Default Re: 2013 GR STI Loss of Power

Did the previous owner include the Accessport in the sale of the car?
UrdnotWrexSTi is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 09-24-19, 04:08 AM   #4
mheyman
Gold Member
Feedback Score: 4 reviews
 
Fav Mod: Camber Camber Camber
My Subaru Parts for sale

Join Date: Feb 2012
Location: SJ USA
mheyman is a glorious beacon of lightmheyman is a glorious beacon of lightmheyman is a glorious beacon of lightmheyman is a glorious beacon of lightmheyman is a glorious beacon of lightmheyman is a glorious beacon of light
Default Re: 2013 GR STI Loss of Power

You and the car are nearish (within 200mi) IAG? Unless you know a great shop, you know what to do.

Can you drive it to em? If you are some what distant and cannot, then join AAA's as a premium member. You get one free trip up to 200mi per year.
__________________
If someone's description of a mod sounds to good to be true, it probably is !!!

If you think you should have lower r's at cruise you're in the wrong car

I become a more loyal IAG customer every time I drive my STI
mheyman is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 09-24-19, 01:11 PM   #5
crick0234
Master Contributor Level 2
Feedback Score: 1 reviews
 
Car: DGM '12 WRX STI 5DR
Fav Mod: shortThrow Shifter
My Threads
Posts: 859
My Subaru Parts for sale

Join Date: Feb 2012
Location: Bay Area, California
crick0234 is on a distinguished road
Default Re: 2013 GR STI Loss of Power

have you checked all lines for boost leak, including ypip from tmic? some of the nuts from the TMIC came loose over the 7 years of my ownership ; retorqued to spec and boost leak gone.

that said tho, i had a lost in power and after that was an increas ein oil consumption, about 1 quart ever 1K miles. Compression test lead to 1 cylinder being lower than the others. having engine rebuilt now.
crick0234 is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


New To Site? Need Help? More

All times are GMT -8. The time now is 09:44 AM.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Designed & Powered by Domain Architect
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.