2013 STI - CEL with P0341 code, how serious of a problem? - Subaru Impreza WRX STI Forums: IWSTI.com
STI Forum
Join
Start New Thread Create Account Advertise FAQ Members List Contact
2013 STI - CEL with P0341 code, how serious of a problem?
2013 STI - CEL with P0341 code, how serious of a problem?
Go Back   STI Forums > > > 2013 STI - CEL with P0341 code, how serious of a problem?
Reply
 
Thread Tools
Old 02-25-17, 05:58 PM   #1
fpsdrop
Becoming A Contributor
Feedback Score: 0 reviews
 
Fav Mod: Coming Soon
My Threads
Posts: 21
My Subaru Parts for sale

Join Date: Dec 2016
fpsdrop is an unknown quantity at this point
Default 2013 STI - CEL with P0341 code, how serious of a problem?

2013 sti, with 43k miles on it, second owner, bone stock besides a invidia n1 catback. Long story short, was going on my usual drive to work driving around 65-70 going up a steep incline and as I was attempting to make a takeover on another car I accidentally downshifted from 6th to 2nd (i know im stupid as shit, lack of attention and being too hard on the stick I guess) and caused myself to redline and was met with the immediate jerk and stutter for half a second before I realized my mistake.

Not soon after I get the dreaded solid CEL + VDC with flashing S drive + Cruise light. Pulled over, stopped the car, waited for 10 mins, restarted and same CEL problem and went on my way to work. Thankfully I didn't notice anything too drastic except for the fact that my car was in limp dick mode for the remaining 15 mile commute. Besides that the car was running fine I guess? engine temps appeared to be good, no further jerk or stuttering, no jerking while in idle.

After work I dropped by the local autozone to see if I could at least get a code for the problem and found the error to be a P0341 OBD2 error code - Camshaft Position Sensor Circuit Range/Performance.

Unfortunately today's a Saturday and none of the Subaru dealerships won't be open until Monday. After doing some research on google and such it seems I'm having trouble finding any other info concerning the P0341 for the STI specifically. One thing's for sure I'm making a trip out to the dealership ASAP once Monday comes, just my question is how serious of a problem is this? The nearest dealership is roughly around 50 miles away and I'm deciding whether its worth it to get towed on over as to prevent any further damage or if I'm safe to make the drive on over.
fpsdrop is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 02-26-17, 12:02 AM   #2
fpsdrop
Becoming A Contributor
Feedback Score: 0 reviews
 
Fav Mod: Coming Soon
My Threads
Posts: 21
My Subaru Parts for sale

Join Date: Dec 2016
fpsdrop is an unknown quantity at this point
Default Re: 2013 STI - CEL with P0341 code, how serious of a problem?

Quick update.

Went in for the noc shift tonight and when I went to start my car there was no CEL. Still drove it lightly around for the first 20 or so miles then pushed the car a bit towards the last 5 miles or so.

Anyways no new changes. Car is still running smooth, temps appear to be fine, oil levels all good, everything seems pretty up to par so far.

After this shift I'm going to plan to drive a bit more just to see if the CEL will turn on again. Either way still shooting for Monday to go to the dealership. Hopefully I'll just pay to run the $150 diagnostic on Monday and be on my way and hope that nothing is wrong with the car. Fingers crossed.
fpsdrop is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help CEL Code 3k1n ECU Tuning & Performance Electronics 5 10-21-10 01:07 PM
CEL with P1091 error code displaying, 2004 WRX STI Elroy079 ECU Tuning & Performance Electronics 8 09-28-09 09:06 AM
CEL problem on stock STi - Final Update, Problem Solved!! Chewyc 2.5 Liter/Litre Factory Motor 15 08-08-06 07:49 AM
newbie with CEL probs (AP can't display error code) Gavinsti FAQ/Newbie Forum 2 06-10-06 07:18 PM
help with cel, weired code "21b6"? hirevn 2.5 Liter/Litre Factory Motor 5 02-09-06 07:41 AM


New To Site? Need Help? More

All times are GMT -8. The time now is 08:24 PM.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Designed & Powered by Domain Architect
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.