Help needed - 2012 STI - R/R hose now car shuts off - Subaru Impreza WRX STI Forums: IWSTI.com
STI Forum
Join
Start New Thread Create Account Advertise FAQ Members List Contact
Help needed - 2012 STI - R/R hose now car shuts off
Help needed - 2012 STI - R/R hose now car shuts off
Go Back   STI Forums > > > Help needed - 2012 STI - R/R hose now car shuts off
Reply
 
Thread Tools
Old 02-08-17, 11:47 PM   #1
mulagain
Becoming A Contributor
Feedback Score: 0 reviews
 
Car: Plasma Blue 5dr '12
Fav Mod: Open Source Stage 2+
My Threads
Posts: 47
My Subaru Parts for sale

Join Date: Apr 2012
Location: Seattle, WA
mulagain is an unknown quantity at this point
Exclamation Help needed - 2012 STI - R/R hose now car shuts off

Hey guys, I need some help here. Maybe it was a dumb thing to do but I removed the hose between the intake manifold and brake booster, heard the pressure release, reinstalled, and now my STI shuts down after about 5 seconds of starting normally. Resetting ECU didn't help. It's also now throwing CEL P1572 "Immobilizer Circuit Failure - Except Antenna Circuit" immediately since doing this and it's not a temporary CEL.

Is this a simple $#*K up that can be fixed easily? I need to get to work in the morning....

Here's the hose I released pressure on:



Off the manifold:


Leading to the brake booster (I think)



CEL P1572:

Last edited by mulagain; 02-09-17 at 12:09 AM.
mulagain is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 02-09-17, 02:07 AM   #2
mulagain
Becoming A Contributor
Feedback Score: 0 reviews
 
Car: Plasma Blue 5dr '12
Fav Mod: Open Source Stage 2+
My Threads
Posts: 47
My Subaru Parts for sale

Join Date: Apr 2012
Location: Seattle, WA
mulagain is an unknown quantity at this point
Default Re: Help needed - 2012 STI - R/R hose now car shuts off

Disregard, problem solved. It turns out it was a bad ECU flash. I reflashed the most recent version my tuner gave me and reset the ECU and its back to normal.
mulagain is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
GR Stumble Mod Fix: GD Style Setup (not hose extension) funks DIY Mods & Installations 127 03-20-19 07:45 PM
To anyone considering a turbo inlet hose install... beware. roninsoldier83 2.5 Liter/Litre Factory Motor 37 04-06-16 08:19 PM
Part needed:: (post intake - hose - not turbo inlet) (pic) esemes 2.5 Liter/Litre Factory Motor 7 12-01-04 07:10 PM


New To Site? Need Help? More

All times are GMT -8. The time now is 10:37 PM.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Designed & Powered by Domain Architect
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.