2004 STi -- Electrical issue after installing turbo inlet pipe - Subaru Impreza WRX STI Forums: IWSTI.com
STI Forum
Join
Start New Thread Create Account Advertise FAQ Members List Contact
2004 STi -- Electrical issue after installing turbo inlet pipe
2004 STi -- Electrical issue after installing turbo inlet pipe
Go Back   STI Forums > > > 2004 STi -- Electrical issue after installing turbo inlet pipe
Reply
 
Thread Tools
Old 09-20-15, 04:43 PM   #1
AWDmaster
Joined the Conversation
Feedback Score: 0 reviews
 
Car: Red 97 BrightonRS
Fav Mod: Coming Soon
My Threads
Posts: 4
My Subaru Parts for sale

Join Date: Jun 2011
AWDmaster is an unknown quantity at this point
Default 2004 STi -- Electrical issue after installing turbo inlet pipe

My friend purchased a 2004 STi a couple weeks ago, and everything has been fine until it suddenly started making half boost. After looking it over, we saw that his turbo inlet hose was looking pretty bad, and he had a TON of vacuum hoses that were very brittle, and broke very easily.

So he got a new inlet pipe, and we decided to pull the manifold so we could replace hoses as we went. I have done several of these, and it was a nightmare as usual

We now have it all back together and it's a no-start. Cranks fine, can't hear any obvious leaks, but the cruise light was flashing with the car off, key on. Hooked up the OBD2 reader and got these...

P0123 Throttle Position Sensor/Switch A Circuit High Input
P0102 Subaru - Mass or Volume Air Flow Circuit Low Input
P0118 Engine Coolant Temperature Circuit High Input
P0113 Intake Air Temperature Circuit High Input
P0108 MAP Pressure Circuit High Input
P0186 Fuel Temperature Sensor 'B' Circuit Range/Performance

So I know it's something electrical. But we have gone over all the obvious connections and everything seems to be nice and snug. I was just wondering if this has happened to anyone else, or if we were just so tired last night that we might have missed something not so obvious.

Any input or direction will help immensely! Thanks for the time.

Last edited by AWDmaster; 09-20-15 at 06:04 PM.
AWDmaster is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 09-20-15, 05:40 PM   #2
farmboss
Advanced Mastery Level II
Feedback Score: 0 reviews
 
Fav Mod: Everything that is actually an improvement over the stock part.
My Subaru Parts for sale

Join Date: Jan 2010
Location: Glen Allen Va
farmboss is on a distinguished road
Default Re: 2004 STi -- Electrical issue after installing turbo inlet pipe

What are the codes for?

You have unplugged something or accidentally tore or frayed a wire enough to break the connection.

The cam position sensor is near there. As well as TGV's...Check all and follow any unprotected parts of the wires.

Check grounds

EDIT=P0123 is for the throttle position sensor...And that is near it as well...Check all wires thoroughly and check harness for proper voltage if its not something simple.

And stick a screw driver on your injectors and listen to see if they're clicking. If its it's something electrical(cam,crank im sure some others) then they shouldn't fire.

And now that I remember, a main harness loom of wires wraps over the turbo inlet. Check in that area for an accidental wire fracture of any kind...Report back

Last edited by farmboss; 09-20-15 at 05:52 PM.
farmboss is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 09-20-15, 06:11 PM   #3
AWDmaster
Joined the Conversation
Feedback Score: 0 reviews
 
Car: Red 97 BrightonRS
Fav Mod: Coming Soon
My Threads
Posts: 4
My Subaru Parts for sale

Join Date: Jun 2011
AWDmaster is an unknown quantity at this point
Default Re: 2004 STi -- Electrical issue after installing turbo inlet pipe

Updated original post with code descriptions.

We have been following and checking wires for a couple hours now. We haven't found anything out of the ordinary.

We checked the grounds on either side of the intake manifold, as well as the main ground to the battery and the green/black wire that goes into the main harness connector.

Going to poke around some more. Thanks for the reply!
AWDmaster is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Old 09-20-15, 06:43 PM   #4
AWDmaster
Joined the Conversation
Feedback Score: 0 reviews
 
Car: Red 97 BrightonRS
Fav Mod: Coming Soon
My Threads
Posts: 4
My Subaru Parts for sale

Join Date: Jun 2011
AWDmaster is an unknown quantity at this point
Default Re: 2004 STi -- Electrical issue after installing turbo inlet pipe

Another update:

Checked injectors, they are clicking.

Pulled a coil to test for spark and it IS getting spark.

Looking for my multimeter at the moment. Does anyone know of a good place for diagrams?
AWDmaster is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 09-21-15, 04:30 AM   #5
farmboss
Advanced Mastery Level II
Feedback Score: 0 reviews
 
Fav Mod: Everything that is actually an improvement over the stock part.
My Subaru Parts for sale

Join Date: Jan 2010
Location: Glen Allen Va
farmboss is on a distinguished road
Default Re: 2004 STi -- Electrical issue after installing turbo inlet pipe

Well shoot some starting fluid in there if oyur getting spark and fuel...It should fire up unless something big is clogged up in the intake since yall messed with it. It could be flooded some how. Its happened to mine after cleaning the I/C and pipes with gas.

Could you smell fresh fuel being from the cylinder you pulled the plug on? Im pretty sure the injector wont click if it doesn't fire. Not 100% on that but smelling the fuel from the cylinder will tell you though.

Everything you'll need to know will be here... 2004 Subaru Impreza WRX STi

If you don't here it catching at all then it can't be getting gas. And the timing wasn't messed with so that isn't a problem.

Last edited by farmboss; 09-21-15 at 04:35 AM.
farmboss is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 09-21-15, 04:48 AM   #6
farmboss
Advanced Mastery Level II
Feedback Score: 0 reviews
 
Fav Mod: Everything that is actually an improvement over the stock part.
My Subaru Parts for sale

Join Date: Jan 2010
Location: Glen Allen Va
farmboss is on a distinguished road
Default Re: 2004 STi -- Electrical issue after installing turbo inlet pipe

most if not all of those code can be found on this page with ways to diagnose... http://ken-gilbert.com/wrx/STi_Manual/02.%20ENGINE%20SECTION%20%28STi%29/11.%20ENGINE%20%28DIAGNOSTICS%29/18.%20Diagnostic%20Procedure%20with%20Diagnostic%2 0Trouble%20Code%20%28DTC%29.pdf

Yall must be over looking something if it ran fine before this.
farmboss is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 09-24-15, 09:19 PM   #7
AWDmaster
Joined the Conversation
Feedback Score: 0 reviews
 
Car: Red 97 BrightonRS
Fav Mod: Coming Soon
My Threads
Posts: 4
My Subaru Parts for sale

Join Date: Jun 2011
AWDmaster is an unknown quantity at this point
Default Re: 2004 STi -- Electrical issue after installing turbo inlet pipe

Thank you everyone! I meant to post this a few days ago... What happened was:

My friend had turned the key to the "ON" position when everything was apart... to charge his phone. That is where the codes came from.

The reason it wouldn't start was because he hooked the fuel lines at the manifold up backwards. Derp.

Again, thank you guys. For everyone else, remember to check the basics! I almost tore the whole thing apart again...
AWDmaster is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 09-25-15, 04:42 AM   #8
farmboss
Advanced Mastery Level II
Feedback Score: 0 reviews
 
Fav Mod: Everything that is actually an improvement over the stock part.
My Subaru Parts for sale

Join Date: Jan 2010
Location: Glen Allen Va
farmboss is on a distinguished road
Default Re: 2004 STi -- Electrical issue after installing turbo inlet pipe

Gotta label stuff so that doesn't happen.

PPP PPP...Prior Planning Prevents Piss Poor Performance
farmboss is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Agency Power Hard Turbo Inlet Pipe DarkwingDuck Engine/Drivetrain/Performance Parts For Sale 0 07-10-15 03:42 PM
Extremely good info for first time turbo owners (Determining Turbo Serviceability) Ursalog 2.5 Liter/Litre Factory Motor 18 10-03-13 11:40 AM
APS Turbo Inlet Pipe Coupler bambam09 WTB/WTT Classifieds 0 09-25-13 04:53 AM
FS (USA,FL): ((sold))FP Black 82HTA Turbo w/ 84mm Inlet Pipe *NIB* ((sold)) STiBriT Engine/Drivetrain/Performance Parts For Sale 6 01-25-13 06:10 AM
Turbo Inlet Pipe rfawley024 2.5 Liter/Litre Factory Motor 1 03-30-07 08:39 AM


New To Site? Need Help? More

All times are GMT -8. The time now is 09:06 AM.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Designed & Powered by Domain Architect
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.