WOT stutter / hesitation / missing - Subaru Impreza WRX STI Forums: IWSTI.com
STI Forum
Join
STI Products
Start New Thread Create Account Advertise FAQ Members List Contact
WOT stutter / hesitation / missing
WOT stutter / hesitation / missing
Go Back   STI Forums > > > WOT stutter / hesitation / missing
Welcome to IWSTI - The world's largest Subaru Impreza WRX STI forum!
WOT stutter / hesitation / missing
WOT stutter / hesitation / missing
WOT stutter / hesitation / missing
WOT stutter / hesitation / missing
Welcome to the IWSTI.com Subaru Impreza WRX STI forum.

You are currently viewing IWSTI.com as a guest, which limits your ability to access discussions, ask technical questions, and learn more about the Subaru Impreza WRX STi models. Join for free today and unlock full access to post topics, communicate privately with other members (PM), respond to polls, share content, and access many other special features. Join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see this welcome message.
Reply
 
Thread Tools
Old 05-10-17, 01:25 PM   #1
DanielC409
Silver Member
Feedback Score: 2 reviews
 
Fav Mod: Coming Soon
My Subaru Parts for sale

Join Date: Dec 2010
Location: Port Arthur, TX
DanielC409 is an unknown quantity at this point
Default WOT stutter / hesitation / missing

Current issue:

When I go WOT or even close to WOT, the car won't even go up in RPMs. It stutters and misses like crazy. It will not throw an immediate code so I can't list it. But in the past it has thrown the p0304 code but never chased the problem down.

Awhile back, the inline fuse holder on my fuel pump pretty much burned up ( my fuel pump is hardwired ). This wouldn't allow the pump to prime so I replaced the wire and eventually the fuel pump and I got it running again. First i replaced the wire and it wouldn't start but I later realized the wiring became disconnected at the butt connectors so the new fuel pump wasn't necessary.

But anyways .. here is a quick datalog. I basically went into WOT as best as I could and it just wouldn't do anything but miss like crazy. This isn't the 3k rpm stutter, it's 10x worse than that and won't ever get past the stutter / miss.

datalog18 - Google Sheets

I took out cylinder 4 spark plug to check it and the gap was too wide so I closed it in to .028 but didn't remedy the issue.

Driving under light load isn't bad and it'll go into the higher RPMs but as soon as I go heavy on the throttle, it just falls apart. I'm not seeing any smoke and I removed the oil filler cap when I got home and no smoke either. When i blip the throttle while I'm at a standstill, there is a slight hesitation before the RPMs go up.

I know the possibilities could be spark plug, injector, coil pack .. I'm just not sure how to check them all without a code to swap them to other cylinders. It usually takes days for the code to show.

Any recommendations that I could mess with before taking it to a shop? Nearest tuner is 2hrs away.

Engine mods:
Walbro 450LPH E85 fuel pump
TSM 1150 injectors
HKS el headers
Cobb sf intake
TopSpeed Protuned
Perrin turbo inlet
E85

Attached Thumbnails
WOT stutter / hesitation / missing-plug-jpg  
DanielC409 is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 05-10-17, 04:12 PM   #2
farmboss
Advanced Mastery Level II
Feedback Score: 0 reviews
 
Fav Mod: Everything that is actually an improvement over the stock part.
My Subaru Parts for sale

Join Date: Jan 2010
Location: Glen Allen Va
farmboss is on a distinguished road
Default Re: WOT stutter / hesitation / missing

What was the gap at? Swap your coils around and see if the missfire follows it. Use your accesport to monitor roughness in all the cylinders.

Whats your a/f correction during normal driving? You still using the maf sensor?
farmboss is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 05-10-17, 04:30 PM   #3
DanielC409
Silver Member
Feedback Score: 2 reviews
 
Fav Mod: Coming Soon
My Subaru Parts for sale

Join Date: Dec 2010
Location: Port Arthur, TX
DanielC409 is an unknown quantity at this point
Default Re: WOT stutter / hesitation / missing

The gap was over .030. Ive monitored roughness before but never really seen much so I'm not sure if swapping the coil would help at the moment. I've only noticed knock on cylinder 4 while monitoring it but I hear that's sort of common. It was at like 5 after I did those logs.

I'm still using the stock MAF sensor and I'd have to log a regular cruise. I haven't driven in a couple of months since I just got it to start yesterday.
DanielC409 is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 05-10-17, 04:31 PM   #4
mheyman
Silver Member
Feedback Score: 4 reviews
 
Fav Mod: Nomal wear & tear
My Subaru Parts for sale

Join Date: Feb 2012
Location: SJ USA
mheyman is a jewel in the roughmheyman is a jewel in the roughmheyman is a jewel in the roughmheyman is a jewel in the rough
Default Re: WOT stutter / hesitation / missing

Sound like fuel to me, and with the fuel pump issues you had I'd guess they aren't all ironed out yet. FYI, I just had an issue the sounded like yours and I think it was the fuel filter that had 200k on it. I wouldn't push it till you have it fixed whatever it is.
__________________
If someone's description of a mod sounds to good to be true, it probably is !!!

If you think you should have lower r's at cruise you're in the wrong car

I become a more loyal IAG customer every time I drive my STI
mheyman is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 05-10-17, 07:10 PM   #5
DanielC409
Silver Member
Feedback Score: 2 reviews
 
Fav Mod: Coming Soon
My Subaru Parts for sale

Join Date: Dec 2010
Location: Port Arthur, TX
DanielC409 is an unknown quantity at this point
Default Re: WOT stutter / hesitation / missing

Yea I'm at 55k miles or so. I'd like to do all that I can before having to bring it in to a shop.

I'm not sure what caused the inline fuse to burn up. That's a bit out of my scope of knowledge.

If I pull the injector, do I need to clamp it off to prevent fuel from leaking or will it be pretty minimal? Maybe I can at least look at it and see if anything looks out of whack.

*I just noticed I pulled the wrong plug. Cylinder 4 is driver side rear? Closer to the cabin? For some reason I thought it was driver front. Guess I'll pull the correct one tomorrow and have a look! /facepalm

**Went ahead and pulled the plug / coil .. this one definitely looks worse than cylinder 2's plug and it was at .035. The coil pack does have some black marks on the end as you might be able to see.
Attached Thumbnails
WOT stutter / hesitation / missing-cylinder-4-spark-plug-jpg   WOT stutter / hesitation / missing-cylinder-4-plug-close-jpg   WOT stutter / hesitation / missing-coil-pack-4-jpg  

Last edited by DanielC409; 05-10-17 at 08:08 PM.
DanielC409 is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 05-12-17, 05:14 PM   #6
farmboss
Advanced Mastery Level II
Feedback Score: 0 reviews
 
Fav Mod: Everything that is actually an improvement over the stock part.
My Subaru Parts for sale

Join Date: Jan 2010
Location: Glen Allen Va
farmboss is on a distinguished road
Default Re: WOT stutter / hesitation / missing

my lord, put fresh denso coppers in or something man.

Gap them all to 28-30, you could be be over volting the coil packs at that gap.
farmboss is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 05-13-17, 06:35 AM   #7
mheyman
Silver Member
Feedback Score: 4 reviews
 
Fav Mod: Nomal wear & tear
My Subaru Parts for sale

Join Date: Feb 2012
Location: SJ USA
mheyman is a jewel in the roughmheyman is a jewel in the roughmheyman is a jewel in the roughmheyman is a jewel in the rough
Default Re: WOT stutter / hesitation / missing

and clean the coil-pack(s). Those look like arc tracks. Use a solvent, like alcohol. Try a que-tip on the inside? Whatever work and leaves no residue.

But honestly it sounds like you need help
__________________
If someone's description of a mod sounds to good to be true, it probably is !!!

If you think you should have lower r's at cruise you're in the wrong car

I become a more loyal IAG customer every time I drive my STI
mheyman is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 05-15-17, 11:19 AM   #8
DanielC409
Silver Member
Feedback Score: 2 reviews
 
Fav Mod: Coming Soon
My Subaru Parts for sale

Join Date: Dec 2010
Location: Port Arthur, TX
DanielC409 is an unknown quantity at this point
Default Re: WOT stutter / hesitation / missing

I've got some new plugs on the way and will gap them accordingly. If nothing changes, I'll be taking her in.
DanielC409 is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 05-17-17, 02:19 PM   #9
DanielC409
Silver Member
Feedback Score: 2 reviews
 
Fav Mod: Coming Soon
My Subaru Parts for sale

Join Date: Dec 2010
Location: Port Arthur, TX
DanielC409 is an unknown quantity at this point
Default Re: WOT stutter / hesitation / missing

Changed the plugs today but still the same issue. I do notice a miss at idle. Roughness idle on cylinder 4 only showed 3 after idle and a trip around the block. Guess I'll swap the coil pack and see if the roughness moves .. I'm guessing it's going to be a fueling issue though.
DanielC409 is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Old 05-17-17, 03:35 PM   #10
DanielC409
Silver Member
Feedback Score: 2 reviews
 
Fav Mod: Coming Soon
My Subaru Parts for sale

Join Date: Dec 2010
Location: Port Arthur, TX
DanielC409 is an unknown quantity at this point
Default Re: WOT stutter / hesitation / missing

Big problem found ( cracked header ).. possibly the root of the issue?

Well after messing around with my plugs, I noticed the heat wrap on my header was coming off and I did notice my engine was really hot after a short spin ( not sure if this would cause the excessive heat ) so I peaked my head underneath and seen that the underbody tray was melted in a couple of places. Sure enough, there are cracks at the welds ..

Could this be the main root of my issues? I'm not sure if this would cause a misfire code etc. I'm not exactly sure when it happened.

Also there is a bit of fluid and I'm not sure where it's from. Doesn't look like it came from the oil pan /drip down.
Attached Thumbnails
WOT stutter / hesitation / missing-cracked-header-1-jpg   WOT stutter / hesitation / missing-cracked-header-2-jpg   WOT stutter / hesitation / missing-fluid-1-jpg   WOT stutter / hesitation / missing-fluid-2-jpg  
DanielC409 is offline  
Likes 0 Dislikes 0
 
Reply With Quote
Reply

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


New To Site? Need Help? More

All times are GMT -8. The time now is 12:15 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Designed & Powered by Domain Architect
Privacy Policy