[FIXED] Crank but no start - Page 2 - Subaru Impreza WRX STI Forums: IWSTI.com
STI Forum
Join
STI Products
Start New Thread Create Account Advertise FAQ Members List Contact
Go Back   STI Forums > IWSTI Engine & Drivetrain > 2.5 Liter/Litre Factory Motor > [FIXED] Crank but no start
Welcome to IWSTI - The world's largest Subaru Impreza WRX STI forum!
Welcome to the IWSTI.com Subaru Impreza WRX STI forum.

You are currently viewing IWSTI.com as a guest, which limits your ability to access discussions, ask technical questions, and learn more about the Subaru Impreza WRX STi models. Join for free today and unlock full access to post topics, communicate privately with other members (PM), respond to polls, share content, and access many other special features. Join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see this welcome message.
Reply
 
Thread Tools
Old 12-26-12, 10:27 AM   #11
Contributor
Feedback Score: 0 reviews
 
Car: WRB 2005 WRX STI
Fav Mod: Cobb Tuning
My Threads
Posts: 67
My Subaru Parts for sale

Join Date: May 2009
Location: Central Valley, CA
jksmdx is an unknown quantity at this point
Default Re: Need help!!!!ASAP Crank but no start

Ok thanks i will try that.

jksmdx is offline   Reply With Quote
Old 12-27-12, 07:24 AM   #12
Contributor
Feedback Score: 0 reviews
 
Car: WRB 2005 WRX STI
Fav Mod: Cobb Tuning
My Threads
Posts: 67
My Subaru Parts for sale

Join Date: May 2009
Location: Central Valley, CA
jksmdx is an unknown quantity at this point
Default Re: Need help!!!!ASAP Crank but no start

bump for help!!!
jksmdx is offline   Reply With Quote
Old 12-27-12, 07:30 AM   #13
Yimi Tuned
Feedback Score: 0 reviews
 
Fav Mod: EWG & Equal Length Header
My Subaru Parts for sale

Join Date: May 2009
Location: Scranton, PA
Hellchaser is an unknown quantity at this point
Default Re: Need help!!!!ASAP Crank but no start

Maybe try uploading a video. Did this happen once you installed the new motor? Is your starter not installed correctly? I really don't know what else to say with out actually being there.
Hellchaser is offline   Reply With Quote
Old 12-27-12, 07:44 AM   #14
Silver Member
Feedback Score: 4 reviews
 
Car: '05 WRB STi
Fav Mod: JDM V8 seats.
My Threads
Posts: 894
My Subaru Parts for sale

Join Date: Sep 2010
Location: north jerz
BootsJunkie is an unknown quantity at this point
Default Re: Need help!!!!ASAP Crank but no start

FWIW, I was havin a progressively harder and harder to start problem, turned out to be my Crank sensor. $30 part from rockauto, starts perfectly every time now!
__________________
2000 Acura TL - DD
2005 Stage2.5 WRB STi : 293awhp, 321awtq @17 psi

Ivey Tuned - Advan - Cobb - TurboXS - Defi - Innovate - Walbro - DeatschWerks - Feal - H&R - Alpine - Infiniti - Curt

2007 Sea-Doo RXT 215 - ET 127 S/C wheel, 3" intake, free flow exhaust, catch can, Rule bilge pump
BootsJunkie is offline   Reply With Quote
Old 12-28-12, 05:28 PM   #15
Contributor
Feedback Score: 0 reviews
 
Car: WRB 2005 WRX STI
Fav Mod: Cobb Tuning
My Threads
Posts: 67
My Subaru Parts for sale

Join Date: May 2009
Location: Central Valley, CA
jksmdx is an unknown quantity at this point
Default Re: Need help!!!!ASAP Crank but no start

THANK YOU BooSTi05, EJThor, willub, Hellchaser AND BootsJunkie FOR HELPING TO LOCATE THE PROBLEM.

Last edited by jksmdx; 12-28-12 at 05:39 PM.
jksmdx is offline   Reply With Quote
Old 12-28-12, 05:48 PM   #16
Yimi Tuned
Feedback Score: 0 reviews
 
Fav Mod: EWG & Equal Length Header
My Subaru Parts for sale

Join Date: May 2009
Location: Scranton, PA
Hellchaser is an unknown quantity at this point
Default Re: Need help!!!!ASAP Crank but no start

Quote:
Originally Posted by jksmdx View Post
THANK YOU BooSTi05, EJThor, willub, Hellchaser AND BootsJunkie FOR HELPING TO LOCATE THE PROBLEM.
No problemo man, I'm always down to help
Hellchaser is offline   Reply With Quote
Old 01-01-13, 02:50 PM   #17
Becoming A Contributor
Feedback Score: 0 reviews
 
Car: CGM 06 WRX LTD
Fav Mod: Coming Soon
My Threads
Posts: 35
My Subaru Parts for sale

Join Date: Aug 2012
nutinbuthehits is an unknown quantity at this point
Default Re: [FIXED] Crank but no start

is it possible that the crank sensor just goes out of nowhere??
nutinbuthehits is offline   Reply With Quote
Old 01-02-13, 09:19 AM   #18
Contributor
Feedback Score: 0 reviews
 
Car: Black 09 WRX STI
Fav Mod: Coming Soon
My Threads
Posts: 50
My Subaru Parts for sale

Join Date: Dec 2011
Location: Guatemala
Marvin54 is an unknown quantity at this point
Default Re: [FIXED] Crank but no start

the problem was the crankshaft sensor or timing belt?

I have the same problem on my sti 09
Marvin54 is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



New To Site? Need Help? More

All times are GMT -8. The time now is 01:43 PM.


Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Designed & Powered by Domain Architect
Privacy Policy