Flashing Cruise light + CEL, Code P0011?? - Subaru Impreza WRX STI Forums: IWSTI.com
STI Forum
Join
STI Products
Start New Thread Create Account Advertise FAQ Members List Contact
Go Back   STI Forums > IWSTI Engine & Drivetrain > 2.5 Liter/Litre Factory Motor > Flashing Cruise light + CEL, Code P0011??
Welcome to IWSTI - The world's largest Subaru Impreza WRX STI forum!
Welcome to the IWSTI.com Subaru Impreza WRX STI forum.

You are currently viewing IWSTI.com as a guest, which limits your ability to access discussions, ask technical questions, and learn more about the Subaru Impreza WRX STi models. Join for free today and unlock full access to post topics, communicate privately with other members (PM), respond to polls, share content, and access many other special features. Join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see this welcome message.
Reply
 
Thread Tools
Old 03-30-12, 03:24 PM   #1
Contributor
Feedback Score: 1 reviews
 
Car: 06 Black STI
Fav Mod: COBB Accessport :)
My Threads
Posts: 51
My Subaru Parts for sale

Join Date: Mar 2012
Location: Idaho
sti-noob is an unknown quantity at this point
Lightbulb Flashing Cruise light + CEL, Code P0011??

So today I went on about a 50 trip and used my cruise control on the highway. When I got to my destination the cruise control light started flashing and a CEL came on.

Ive read on other similar threads what the problem might be but I wanted to get the code and share it with you guys to get a second opinion on what it might be?

just an fyi its a 06' sti, and mods are COBB Sf intake, HKS DP + HKS UP.

from what Ive read everyone says to get a tune ASAP?

I just got the car a week ago and try to stay out of boost until I get payed on the 7th to get my AP.

Help?!

sti-noob is offline   Reply With Quote
Old 03-30-12, 07:26 PM   #2
Advanced Contributor Level 2
Feedback Score: 0 reviews
 
Car: 05 WRX/STi Black
Fav Mod: Coming Soon
My Threads
Posts: 222
My Subaru Parts for sale

Join Date: Jul 2005
massivslinky is on a distinguished road
Default Re: Flashing Cruise light + CEL, Code P0011??

Just a wild guess, but it's probably running lean from the intake. The exhaust is also flowing way more. Basically your ECU has no idea what to do with all this new air flow. If it were my car, I'd not even drive it until fixing the tune.

Quote:
Originally Posted by sti-noob View Post
So today I went on about a 50 trip and used my cruise control on the highway. When I got to my destination the cruise control light started flashing and a CEL came on.

Ive read on other similar threads what the problem might be but I wanted to get the code and share it with you guys to get a second opinion on what it might be?

just an fyi its a 06' sti, and mods are COBB Sf intake, HKS DP + HKS UP.

from what Ive read everyone says to get a tune ASAP?

I just got the car a week ago and try to stay out of boost until I get payed on the 7th to get my AP.

Help?!
massivslinky is offline   Reply With Quote
Old 03-30-12, 09:04 PM   #3
Contributor
Feedback Score: 1 reviews
 
Car: 06 Black STI
Fav Mod: COBB Accessport :)
My Threads
Posts: 51
My Subaru Parts for sale

Join Date: Mar 2012
Location: Idaho
sti-noob is an unknown quantity at this point
Default Re: Flashing Cruise light + CEL, Code P0011??

I agree, ive been trying to drive another car as much as I until I get that accessport.

Lol 98 grand Marquis it is xD
sti-noob is offline   Reply With Quote
Old 03-31-12, 11:53 AM   #4
Becoming A Contributor
Feedback Score: 0 reviews
 
Car: SWP '07 STi Limited
Fav Mod: Access Port
My Threads
Posts: 25
My Subaru Parts for sale

Join Date: Apr 2011
Location: Edmonton, AB, Canada
Mustard is an unknown quantity at this point
Default Re: Flashing Cruise light + CEL, Code P0011??

I had this code a while back...

turns out i was running on almost zero oil. Not saying this is your problem, but saying it might be a good thing to check.
Mustard is offline   Reply With Quote
Old 03-31-12, 03:56 PM   #5
Contributor
Feedback Score: 1 reviews
 
Car: 06 Black STI
Fav Mod: COBB Accessport :)
My Threads
Posts: 51
My Subaru Parts for sale

Join Date: Mar 2012
Location: Idaho
sti-noob is an unknown quantity at this point
Default Re: Flashing Cruise light + CEL, Code P0011??

Oil looks ok for the most part, probably going to change here soon tho

btw is it me or does anyone else have a hoot trying to figure out how much oil is on the dang dipstick for these cars? every time I check it its always like splashed on the bottom of the dipstick, I assume its full because the oil reaches the line but Idk it just seems odd
sti-noob is offline   Reply With Quote
Old 04-29-12, 12:43 PM   #6
Becoming An Advanced Contributor
Feedback Score: 0 reviews
 
My Threads
Posts: 99
My Subaru Parts for sale

Join Date: Dec 2011
Location: Lodi, CA
racefreak156 is an unknown quantity at this point
Default Re: Flashing Cruise light + CEL, Code P0011??

I have the same problem. But dont have any mods. But my cruise flashes and i never use it, plus the CEL is on. Ran my obd2 and says P0011 intake (a) camshaft position timing advanced (bank a). Anyone else have the same problem???
racefreak156 is online now   Reply With Quote
Old 04-30-12, 02:39 AM   #7
Contributor
Feedback Score: 1 reviews
 
Car: 06 Black STI
Fav Mod: COBB Accessport :)
My Threads
Posts: 51
My Subaru Parts for sale

Join Date: Mar 2012
Location: Idaho
sti-noob is an unknown quantity at this point
Default Re: Flashing Cruise light + CEL, Code P0011??

turns out that my problem was the infamous Banjo bolt oil feed line that goes to the turbo was clogged.

I ignored it and payed for my ignorance, now I have to replace my turbo

what happens is that the oil line that runs to ur turbo gets clogged and starves ur turbo...

I STRONGLY SUGGEST you stop driving the car regularly and do one of these things:

pull the heat shield off your turbo, pull the the banjo bolt off the top of the midsection of your turbo, and check to see if its clean. If it has a little screen in it you might even want to throw that little screen out. Then, pull the ignition fuse from your fuse box and turn the engine over for about 15 seconds. this should pump oil through the oil line and if you dont see any dumping out you might want to dig deeper into the issue and check the banjo bolt under the turbo by the up-pipe

take it to a Subaru shop as it is a common issue and they could help you figure it out.

take my advice tho and DONT ignore the issue. I ignored it and blew my turbo.

best of luck to ya
sti-noob is offline   Reply With Quote
Old 05-01-12, 03:59 AM   #8
Becoming An Advanced Contributor
Feedback Score: 0 reviews
 
My Threads
Posts: 99
My Subaru Parts for sale

Join Date: Dec 2011
Location: Lodi, CA
racefreak156 is an unknown quantity at this point
Default Re: Flashing Cruise light + CEL, Code P0011??

I figured out my problem was that it needed oil but plan on getting a oil change since i just got it a month ago and dont know when the last time it had one. Bought what i need just need the time to do it. Seems like there is many things that it can be just in one code for the cel. Pays to do all the research you can and then try the fixes yourself before dropping a lot of money at the dealer.
racefreak156 is online now   Reply With Quote
Old 05-01-12, 06:11 AM   #9
Advanced Mastery Level I
Feedback Score: 13 reviews
 
Fav Mod: 317hp/350tq@16psi
My Subaru Parts for sale

Join Date: Nov 2008
Location: Albuquerque, NM
ImAmekanic is an unknown quantity at this point
Default

U need to replace the banjo bolt for the turbo and check the screen filter. I had same code and eventually my motor died after replacing turbo. Will prob need to do an oil flush as well since that's what the dealer will do anyway. What oil is in it now?


---
I am here: http://tapatalk.com/map.php?sfv1et
ImAmekanic is offline   Reply With Quote
Old 05-06-12, 12:26 AM   #10
Contributor
Feedback Score: 1 reviews
 
Car: 06 Black STI
Fav Mod: COBB Accessport :)
My Threads
Posts: 51
My Subaru Parts for sale

Join Date: Mar 2012
Location: Idaho
sti-noob is an unknown quantity at this point
Default Re: Flashing Cruise light + CEL, Code P0011??

Quote:
Originally Posted by beepbeep View Post
U need to replace the banjo bolt for the turbo and check the screen filter. I had same code and eventually my motor died after replacing turbo. Will prob need to do an oil flush as well since that's what the dealer will do anyway. What oil is in it now?


---
I am here: http://tapatalk.com/map.php?sfv1et

I just changed the turbo in mine as well. did the same code appear right after you replaced it? did you get any signs that pointed to the engine going out before hand?
sti-noob is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



New To Site? Need Help? More

All times are GMT -8. The time now is 08:23 PM.


Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Designed & Powered by Domain Architect
Privacy Policy